How do I connect my Porkbun domain to my Linode server?

Hi! I know nothing and I would appreciate a little guidance.

In my Linode, I've tried going to:
Domains > Add a domain (I typed my domain, email and set it to master).

In Porkbun:
Added the NS Records found in the domain section I just added in Linode under the AUTHORITATIVE NAMESERVERS section in Porkbun.

Waited two days. Resulted in nothing.

I also tried resetting the AUTHORITATIVE NAMESERVERS to the default Porkbun provides and then changing the AAAA records to point to the Linode's IP (one with an empty host, another one with a "www" host, both with the default TTL of 300). No CNAME or MX record.

Waited two days. Resulted in nothing.

What should I do? Thanks so much if anyone takes some time off their day to help.

2 Replies

Without being able to see your domain, it's a bit difficult to say for sure what may be stopping the domain from resolving. The steps you've listed here sound correct. As long as you have an A record pointing to your Linode's IP address, with both a blank hostname and a www hostname, that domain should resolve. When you run the command dig +short $domainname, do you get a response back with the IP address for your Linode? If so, there may be a misconfiguration in your web server itself that's preventing the content of your site from being served. In that case, you'll need to ensure that your domain and document root path are correct in your virtual hosts file.


Running that command returns the following:

My linode is a one-click wordpress configuration.

What information can I share with you to diagnose the issue further?


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct