Certbot Apache, SFTP wont connect

I have lets encrypt cert set up for my site, with the apache wordpress setup.

I tried to scp or sftp (client), neither connect now.
SSH connects, but the other two just time out though once I got connection refused on my sftp client.

What do I need to change?


4 Replies

Do you have the following entry:

Subsystem sftp /usr/lib/openssh/sftp-server

in your /etc/ssh/sshd_config file?

-- sw

Yep its there, not commented out.

Here's all the non-commented out stuff in my /etc/ssh/sshd_config:

PermitRootLogin no
IgnoreRhosts yes
PasswordAuthentication no
ChallengeResponseAuthentication no
UsePAM yes
PrintMotd no
PidFile /var/run/sshd/sshd.pid
AcceptEnv LANG LC_*
Subsystem    sftp    /usr/lib/openssh/sftp-server

I use keys exclusively for authentication…no password authentication…YMMV. I also do not allow root logins over ssh(1).

I'm assuming that since ssh(1) works, that there's no firewall issue.

Here's another thought… scp(1) executes scp -t on the remote side, so scp(1) needs to be available there too. Are openssh-clients installed there?

Any information in /var/log/auth.log?

-- sw

@stevewi Thank you for being so helpful.

I didn't see anything on the linode itself to be wrong, but this was a great exercise on how to verify everything.

I'm saving this page.

It ended up being fixed by deleting the Filezilla and reinstalling. STFP worked fine after this.

As for the scp, as you suggested it has to be on the server side.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct