Incorrect domains showing after HTTPS change

Have a problem. I run a server using Webmin/Virtualmin and today decided to add SSL to one of the sites (there's 9 or 10 of them on the same server). I followed the instructions, and I appear to have done it correctly. here's the site:

However, when I view the site (via just http) from my personal browser, I see a wrong site (the Cozy Powell site). If I view the site from my personal browser, but with https, I see my Black Sabbath site (which is correctly configured with https).

If I go through VPN Proxy, I do see the correct blog with https active, and a secure note. So that's good.

Now all this SOUNDS like a DNS issue, but I wasn't aware jacking with https would affect DNS like this. Can anyone let me know? Am I right? Is this just a thing I need to ride out and wait for DNS, or did I screw something up when putting in Virtualmin for SSL. I don't think, so cuz it does show as installed corectly on the VPN connection.
FYI: this was the page I used for SSL installation instructions.

If this does turn out to be a DNS thing I need to ride out, I'll change TTL to something like 5 mins a day before I try another domain for an SSL upgrade. :)

If it's something else, I'm at a loss - the guy who set up my server with Linode originally has disappeared, and I'm trying to muddle my way through here.

8 Replies

If I browse to (on HTTP) I get redirected to the same site on HTTPS - and get the “a cup of Joe” blog.

Is that correct?

Do you have an example of another domain on that server that you are seeing incorrectly?

Is it possible the HTTP->HTTPS redirect is listening on all sites, not just the HTTPS-enabled one? Can you share any config files or Webmin screens showing your configuration (redacting any sensitive info of course.)


Hi Andy. That's what it's supposed to be doing. On my own browser, going to the blog link above ends up at the Cozy Powell site on my box.

These two domains are showing up wrong for me now on my own browser: and

My biggest concern is the guy who set up my linode originally has disappeared off the face of the earth, I can't get him in to help me. He'd normally do this stuff, I'm at a loss. I can muddle around a bit, but sometimes I create problems.

"Is it possible the HTTP->HTTPS redirect is listening on all sites, not just the HTTPS-enabled one? Can you share any config files or Webmin screens showing your configuration (redacting any sensitive info of course.)"

I'd be glad to share whatever, but I don't know exactly what it is you're looking for.

Finally, I'd love to know if it's just DNS, but I have to confess to being in a bit of a panic. I'm not liking not being able to find out what the problem is.

Could there be some conflict with the DNS entries in my Linode manager, and the Bind DNS that is running on my server? #StabInTheDark

Ok I think I’ve figured it out.

On an IPv6 network, I get the Ranger Fans site correctly.

But on an IPv4-only network, I get the blog.

The “cup of Joe” blog works fine on an IPv4-only network, but on IPv6, I get the Cozy Powell site - looks like that’s what’s happening for you; you’re a lucky one like me to have an IPv6-enabled ISP!

I think we need to be looking at the IPs and ports for each of the sites in Webmin. (It may be called bindings.)

Your DNS has both an IPv4 address ( and an IPv6 address (2600:3c00::f03c:91ff:fe26:50c6.)

You should ensure that in Webmin, each site has an entry for port 80 on both of those IPs (or show as “any” IP.) Additionally any SSL-enabled site should have an entry for port 443 on both IPs (or “any.”)

If a site is missing an entry, the web server will generally fall back to the first (or default) site for that IP/port combination, explaining why we’re seeing different sites.

OK, I'll go use that. see if it makes any difference (hopefully).

I found this.

Flipped that, and I now can see my blog correctly, but not everything is working right now.

…. think I found the way out. Working on it now.

…. and it all seems fixed. Thanks for the pointer in the right direction, andy!

Changed these lines

<virtualhost *:80=""></virtualhost>


<virtualhost"" [2600:3c00::f03c:91ff:fe26:50c6]:80=""></virtualhost>


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct