Object Storage Error - QuotaExceeded

This is regarding the Object Storage that I have on my account. It has suddenly stopped working and throwing the below error while uploading;

ERROR: S3 error: 403 (QuotaExceeded)

This is very critical for me. As per the documentation, everything is way below the limits.

Please guide on how can I resolve this

3 Replies

This error typically means that your storage quota has been exceeded. There is currently a limit of 50,000,000 objects and 50TiB of storage. It could also indicate that you are being rate limited. If you add a delay to your uploads, do you still see this error occur? If the error disappears, you are likely experiencing rate limiting.

Thanks Jyoo for your prompt response.

I am having 75GB of data distributed across two buckets.
There are total of ~ 400,000 objects.
All these objects individual size ranges from few KBs to few MBs.
I am unable to upload any new file into any of the buckets. I have tried 'AWS SDK for java' and 's3cmd sync' command. They both are throwing the below error:

When I issue the below command
s3cmd sync mail.txt --preserve s3://df-test -P

I get the following output
upload: 'mail.txt' -> 's3://df-test/mail.txt' [1 of 1]
511 of 511 100% in 0s 39.00 kB/s done
ERROR: S3 error: 403 (QuotaExceeded)

Also My uploads are happening via single thread so there is no chance for rate limiting issue while upload operation.

I think there might be some flag set on my object storage which is blocking the uploads.

This issue is persistent for couple of days now and our production release is being impacted due to this issue. Please help.

I had the same problem with you getting the error "ERROR: S3 error: 403 (QuotaExceeded)" and I tried sending a ticket to linode.

the solution I got, it turned out to be a bug from Ceph https://tracker.ceph.com/issues/13223 and they suggested disabling upload or multipart sync I tried to work. can now upload or sync.

To troubleshoot, you can try disabling multipart uploads.

s3cmd -d sync --disable-multipart

These open source s3 utilities may offer a workaround as well:


good luck


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct