Problem with Mail from server being rejected.

One of the domains on my linode runs vBulletin, and the outbound messages are being rejected by Gmail. Here's what I'm seeing in the headers of the rejected message:

host[2607:f8b0:4003:c0b::1b] said: 550-5.7.1 [2600:3c00::f03c:91ff:fe26:50c6] Our system has detected that this 550-5.7.1 message does not meet IPv6 sending guidelines regarding PTR records 550-5.7.1 and authentication. Please review 550-5.7.1 for more information 550 5.7.1 . o6si4719500ote.113 - gsmtp (in reply to end of DATA command) <<

I looked at the link, but I have to confess to not being sure where to go to fix that problem.

Thing is this used to work, and I'm not sure what may have changed except I possibly changed from http to https, but I can't imagine THAT would be the problem.

Can someone point me in the right direction? Tkx.

4 Replies

From the message displayed, it looks as though your emails are being rejected because rDNS (PTR record) is not set up for that IPv6 address. Per the link provided by Google:

Your sending IP address must have a PTR record. PTR records verify that the sending hostname is associated with the sending IP address. Every IP address must map to a hostname in the PTR record.

We have step-by-step instructions for completing this process in our guide, Configure Your Linode for Reverse DNS (rDNS).

DANGER Will Robinson! has other requirements as well -- DKIM, DMARC, SPF. Once you get rDNS sorted out, you may run into those as well. Now you know…

-- sw

I forgot about this thing, and I went to look into it.

My concern in setting up rDNS is this. I don't know what domain to put in the fully qualified thing for ipv6 rDNS. The IP I'm using is shared over about 7 or 8 domain names.

There is an entry in the ipv4 field, should I just replicate that in ipv6?

@JoeSiegler --

You have only one mail server, you should use the domain name of the mail server for your rDNS. If you use postfix(1) use the entry from your postfix(1) configuration as follows (for both IPv4 and IPv6):

myhostname =

You will also have only one MX record -- set up the same way as your rDNS. I'm pretty sure that the lookup goes like this (I'm not a DNS expert & I don't play one on TV):

  1. Look up A/AAAA record for the domain name.
  2. Look up the MX record at the IP address returned from #1.
  3. Send the mail to the mail server at the results of lookup #2.
  4. Hope that the mail server used in #3 has been configured to deliver the mail properly.

Perhaps someone more knowledgeable than me can comment…

Technically, you can have multiple rDNS entries but it's not recommended:

I don't know if the Linode DNS manager allows this though.

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct