glish console: "error: variable 'prefix' isn't set. "

At boot I get a GRUB boot error, in Glish console:
"error: variable 'prefix' isn't set. "

The weblish console is fine. Is there a way to set 'prefix' so I can use glish?

Using weblish is problematic. If I want to use the cursor to change the kernel being booted where I type isn't where the cursor is.

Worse, when dealing with current BLS issues:



I sometimes need to use grub2 to boot the hard way and with weblish just have to give up.

Once the system is booted, glish works perfectly. The problems seems to be only with grub.

If this matters:

Running sudo grub2-install /dev/sda while booted with the Linode kernel shows this:

Installing for i386-pc platform. grub2-install: warning: File system ext2 doesn't support embedding. grub2-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged.. grub2-install: error: will not proceed with blocklists.

Because of the BLS issue, I'm not sure if grub is setup for serial console or not. /etc/default/grub shows serial port is configured (and for now GRUB_ENABLE_BLSCFG=false)

This linode has been around since fedora 19, so there might be baggage left over from pre KVM days.

Any clue appreciated

2 Replies

Hi @bostondriver,

The message you post is a red herring - it's simply the last thing that GRUB outputs before the operating system takes over.

However, if the graphical console isn't configured, there isn't anything to take over the display, so you see this as the last output.

Once the system has booted and the login shell is ready, this output should be replaced. The default Linode config doesn't enable the graphical shell post-GRUB - I presume this is from days before Glish existed, so it only enabled the text serial console for Lish.

Please see this community post of mine where I've posted my Fedora config to use both Lish and Glish during the boot process.

Thanks. I've updated accordingly and now have what I expected.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct