How do I redirect HTTP to HTTPS on browsers?

When someone types in my Wordpress site without explicitly including the https part (just it automatically goes to http://<></>

It doesn't redirect to https://<> within the browser (Firefox, Chrome, Pale Moon).</>

I am already set up with SSL internally. My WordPress is using HTTPS (I have it forced.) I changed both my .htaccess and wp-config.php to reflect this. Also I changed the WordPress Address and Site Address under WordPress's Settings->General to https://<>. This is all for within WordPress. If I'm visiting with any modern browser, I think Apache's settings on my Web site override WordPress when port 80 or port 443 traffic is displayed in the browser?</>

So I think the problem here is Apache? Or is it WordPress? I've already tried changing my <>.conf Apache file and .htaccess, to no avail. Why do browsers automatically go to http://<> while my wordpress is running? Maybe it's Linode or my A/AAAA Record? (domain settings)</></>

3 Replies

This is a server issue. It has nothing to do with WP or DNS.


Also, don’t forget to blow your browser cache before trying what’s recommended in this article.

— sw

Thanks. I tried the suggested code for my port 443 entry in <>.conf.</>

Apache complained about "too many redirects" - the site wouldn't load. So I guess I didn't enter the code correctly or it's something somewhere else.

Did you blow your browser cache (a couple of times) and clean out all the cookies cached in your browser before you tried it? This could also be a problem with plugins you may use. See:

You can also do this with php(1) and apache2 mod_rewrite. See:

Again, you're going to have to blow your browser cache and delete all your cookies before trying any of these. It would probably be helpful to blow your server's cache too:

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct