UFW fails

I installed the Docker , and when ran a upgrade command , my linode throws an 522 error. I checked the UFW status,
it says
modprobe : FATAL : module nfnatftp not found in directory /lib/modules/5.8.3-x86_64-li

I can't run sudo apt update command it fails.

i cant login using ssh , my sites are throwing 522.
Running curl -i google.com says could not resolve host..

Please help me on this

4 Replies

@razamohd --

You know…when you post the same question at multiple Q&A sites, you need to be patient and monitor them all for an answer…not just post over and over and over again because you didn't get an answer fast enough. You posted this same question at:

Someone answered at https://askubuntu.com … You should take that person's advice and disable ufw with systemctl.

-- sw

@razamohd --

You write:

modprobe : FATAL : module nfnatftp not found in directory /lib/modules/5.8.3-x86_64-li[…]

I did some more investigation…

modprobe(8) intelligently adds or removes a module from the Linux kernel. The message above indicates that a dynamically-loaded module ufw(1) expects to be in the the kernel cannot be found (for dynamic loading).

Your system is most likely seriously broken! Not being familiar with Docker, I can't say what exactly happened to cause your system to break this way. You mention an upgrade command in your OP but decline to say what kind…Docker upgrade; apt-get upgrade; dist-upgrade; etc. A failed system upgrade could cause your symptoms…

IMHO, you have 3 options:

  • chuck it and start over;
  • boot to recovery mode and try to repair your system manually (not for the faint of heart…and very time-consuming); or
  • restore from a backup and start over (you do have backups, right?).

-- sw


This is a live server , which caused issue and questions posted in different portals , one is VPS service provider and other one is world known stackoverflow.(There is no limitation that not to post here and there,we all need solutions to questions, it happens to everyone).

Before you come to a conclusion , please understand that i had spent more than a day to fix the issue when i posted the questions.
I had tried all the above mentioned solutions.

Finally i fixed the issue. Its much related to network configurations.


Anyway thank you for you reply . Appreciated.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct