MediaWiki Problems--Can't Edit

Anybody got MediaWiki 1.7.1 working on their Linode? I dumped my home wikis on my Linode while I'm moving cross-country and my home connection is down, but editing isn't working. I just wind up back at the page I was trying to edit.


  • Linode 80

  • CentOS 4 image

  • 1024M Swap

  • httpd-2.0.52-28.ent.centos4

  • mysql-4.1.20-1.RHEL4.1

  • php-5.0.4-5.centos4

Whenever I try to select an "edit" link, it doesn't work, but I get the following error in logs/error_log:

[client A.B.C.D] PHP Fatal error: Allowed memory size of 8388608 bytes exh

austed (tried to allocate 14592 bytes) in APACHEROOT/~user/public_html/mediawiki-1.7.1

/includes/Sanitizer.php on line 861, referer: https://MYSERVER/~user/


Allowed memory size of 8388608 bytes exhausted (tried to allocate 3 bytes)

3 Replies

Have you tried adjusting the PHP memory_limit? (in your php.ini)


Have you tried adjusting the PHP memory_limit? (in your php.ini)

Bam! Thanks!


  • 1024M Swap
    Just thought I'd add that this is way more swap space than you should be running on a Linode 100. Depending on your needs, you might need at the most 512MB, but if you're using more than 256MB of swap space on a Linode 100, you've got other problems to worry about than running out of memory… like swap thrashing.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct