Marketplace provided NextCloud on HTTPS / SSL instead of HTTP

Hello,
I installed NextCloud following the Marketplace setup way.
Unfortunately the setup doesn't run an HTTPS/SSL mode but only a HTTP one although during setup I checked the "Would you like to use a free Let's Encrypt SSL certificate? (Requires domain)" [= yes].
In fact I have the directory /etc/letsencrypt in my Linode machine.

Do you have any document explaining how to properly configure HTTPS/SSL mode for your NextCloud installation?

Thanks

2 Replies

In order to automatically create an SSL certificate with Let's Encrypt for a Nextcloud instance, the Marketplace app requires the appropriate Domain information to be entered upon deployment. If you'd like to take a peek under the hood, you can see exactly what the Marketplace app does here:

Creation of an SSL certificate requires a domain. Given that we don't know the IP address of your Nextcloud Linode before the server is deployed, it isn't possible to have the appropriate zone information in place for the script to do its thing beforehand. This is why the deployment script asks for your Domain, the subdomain you want to use, and an API token with Domain read/write access to create the necessary records. The implication here is that your Domain must be on a Linode account and using Linode's name servers, and I can see that we can probably make that tooltip a bit more clear.

Since you're already up and running with Nextcloud, you should be able to get your SSL up and running by following the normal steps to create an SSL certificate for Apache. The following guide should help you to achieve that, although you'll want to remember to replace all instances of the word "nginx" with "apache" in those commands to make sure the configurations are applied correctly:

Hi, I'm a bit confused here. I already own a domain (on Godaddy) and when I add this domain to Linode when creating a new NextCloud instance (using Market provided instance), then… what? I lost the cue here. Please help out a bit thanks.

PS: I followed the following blog post after setting up the NextCloud Linode: https://www.pragmaticlinux.com/2020/08/how-to-configure-a-domain-name-for-your-linode-vps/

After changing the NameServers on Godaddy, pointing to ns1.linode.com etc. I have seen no effect yet. So can't be sure I achieved anything. Also I'm not even sure it will solve the HTTP/HTTPS issue at all.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct