IP Transfer Swap and reboot still shows old IP address

In Atlanta, I swapped two Linode machine IP address.
Before swap:
linode1 (45… IP address) This is my public machine and in DNS
linode2 (173… IP address) I built a new machine here.

Then I did the IP swap, and it worked half-way:
linode2 is now at (45… IP address). This is good, and the is publicly accessible web and other resources.

But I need to keep the old machine around for a few more days.
And I find I cannot ssh into it.
Linode manager says it has the new 173… IP address, but connections to that address time out.
I can use the could Lish console, and it shows that internally the machine still is holding on to the 45… address, even after a reboot.
"ip a" shows 45….

Is this expected? Do I just have to wait a few hours for the old machine to get the new address shown in the cloud.linode.com console?

1 Reply

To close this issue, turns out the IP Swap failed to fully complete it works correctly.
It only worked partially. Reboots did not fix problem, nor did waiting 12+ hours.

So support said best fix is to use static IP assignments, so did that, and now all is fine.

Followed instructions here:
First, disable the automatic network helper.

Then follow instructions in web page shown below.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct