SSH access on my linode is not working suddenly.

I'm using a linode with docker installed inside.
I use it for remote programming and testing.
So i'm connected to it via VSCode and MobaXterme like 10 hours per day.

It was always working, expect some time in the side of VSCode i need to reconnect. It happen like 2 or 3 times per day.

Today while working on it, i suddenly got disconnected. (In both VSCode and MobaXterm).
I can't reach the ssh access.

  • Tried to ping the serveur, and i got response.
  • Visit some website on it, it's working.
  • Tried ssh -vvv <user>@<host> and it says ssh: connect to host <host> port <port>: Connection timed out
  • I reboot the serveur and cannot still connect via SSH.

Thank's for your help.

1 Reply

Since you're unable to connect to your Linode via SSH, you'll want to access it via Lish to begin your troubleshooting. Once connected, you'll want to consider any recent changes to your Linodes firewall or SSH configuration. If there had been no recent changes, you could start your troubleshooting by verifying that SSH is running; for example, on systemd systems (Arch, Ubuntu 16.04+, Debian 8+, CentOS 7+, etc) you can run:

sudo systemctl status sshd -l

If the service is running, then you'll want to verify which port the service is running on:

sudo netstat -plntu | grep ssh

From there, you will want to verify that your SSH configuration settings are correct, as well as review your SSH logs, to try to pinpoint issues such as another service on your system using the same port that SSH binds to. If the SSH service looks properly configured then you will want to move forward with troubleshooting your network connectivity.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct