inittab keeps getting overwritten on boot! [SOLVED]

Hi everyone,

I'm in the process of moving my server over to Linode, and I've run into a bit of a weird problem. I set up this new server on my local PC and uploaded a disk image to Linode, and the server seems fine except that I can't log in on the console (when I connect to LISH I can see the boot messages but then I get an "INIT: no more processes left in this runlevel" error.)

I figure this error is because no consoles are enabled in /etc/inittab (they're all commented out) but when I uncomment one of the lines and reboot, inittab gets overwritten with the old copy where all the consoles are commented out! I tried it on my local copy of the server and it works fine there, it's only the Linode server that gets inittab overwritten.

The last-modified date on the file is the time I booted the node, so it's definitely getting overwritten during the boot process but I can't for the life of me figure out where! I'm running Gentoo 2006.0, and any pointers would be greatly appreciated!

3 Replies

Well I think I've found a workaround for this - running "chattr +i /etc/inittab" it makes it "super read-only" so that whatever is trying to write to it at startup is unable to do so, and my changes remain intact.

I now have a login prompt again when I log in to LISH - yay! :-)

Odd problem, all right. :)

Hmm. Perhaps do something like:

# find /etc -type f|xargs grep /etc/inittab

Yep, tried that - nothing!

$ find /etc -type f|xargs grep inittab
/etc/inittab:# /etc/inittab:  This file describes how the INIT process should set up
/etc/inittab:# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/files/inittab,v 1.5 2005/12/22 02:03:23 vapier Exp $


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct