How to configure Let's Encrypt Manually?

I use Certbot to install Let's Encrypt certificate. Yet, the is NOT secure and seemed that the certificate it load is that for

I use the following command to get the certificate:

certbot certonly --rsa-key-size 2048 --standalone --agree-tos --no-eff-email --email -d

certbot certonly --rsa-key-size 2048 --standalone --agree-tos --no-eff-email --email -d

Both commands successfully generated the "renewal" of certificate. The problem is that the first one did not work.

I don't know where to start. How can I make this right?

3 Replies

According to an SSL Labs report I ran, the cert for that sub-domain expired on June 18th.

Usually when I run certbot, it will check for all available domains and subdomains on the server and offer you the option to assign a certificate for all of them.

If that is the case then how can I force the server to use the newly renewed certificate? It looks like Certbot successfully renewed the certificate but failed to assign it to the subdomain. This is not my first time renewing the certificate and it always work seamlessly, except for now. I really don't know where to start, running the certbot certonly again already hit the limit.

And in addition, I have another domain with subdomains on the same server and they all works fine.

@LouWestin I followed your link and there is a certificate under the column Additional Certificates (if supplied) that will expire in 3 months. It is supposed to be the certificate to use, not the expired one.

How can I resolve this?


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct