Unsure about domain adding.

I just moved to linode, and I am trying to setup my DNS records for a domain im adding. I think im doing something wrong becuse when i dig the domain name, i don't get anything in the ANSWER section.

I logged in to the DNS management and then clicked on the domain i want to add an A record for, then clicked "New A/AAA Record" and typed the domain name as the hostname and entered the IP i was given. When i click "Add", it shows up as "www" in the list of A records.

Is that correct? Am i doing something wrong?



4 Replies

I think the form for adding A/AAA records is misleading. It shows an example using "www.example.com", but it really actually needs the virtual host name, not the full domain. If you are just adding a record for your top level domain (ie: example.com), then you should leave the hostname field blank (or I think using "@" should work as well). If you are adding a record for "www.example.com", you would specify "www" in the hostname field.

Cool, and how long does it normally take to propagate to the dns servers? The change has been made on the domain but dig is still returning the same results. Works fine in my browser.

$ dig dpn.name

; <<>> DiG 9.2.2 <<>> dpn.name
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56026
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;dpn.name.                      IN      A

dpn.name.               8143    IN      SOA     ns1.linode.com. davidnovakovic.gmail.com. 2007021706 7200 7200 1209600 86400

;; Query time: 47 msec
;; WHEN: Sun Feb 18 11:11:05 2007
;; MSG SIZE  rcvd: 97

Depends on what your cache timeout settings are. From here, it looks like it's updated and working:

;dpn.name.                      IN      A

dpn.name.               86400   IN      A

dpn.name.               86400   IN      NS      ns2.linode.com.
dpn.name.               86400   IN      NS      ns1.linode.com.

ns1.linode.com.         3600    IN      A
ns2.linode.com.         3600    IN      A

;; Query time: 128 msec
;; WHEN: Mon Feb 19 19:03:25 2007

You can use dig to check a specific name server instead of your usual ISP settings (which will likely be cached) to get the info directly from the source like so:

dig @ns1.linode.com dpn.name

Awesome, thanks. Yep all working fine now :)

Ta for the tip.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct