NextCloud Setup: Access Error

So I managed to setup NC on my Linode, however when I tried to access the page using the IP provided. I get the following error:

Access through untrusted domain
Please contact your administrator. If you are an administrator, edit the "trusted_domains" setting in config/config.php like the example in config.sample.php.

Before I lose myself into that rabbit hole, in following the steps I provided a domain as shown and added:

And I already have the domain on an existing CloudFlare with: along with a whole bunch of DNS configs for my email.

I'm not sure where it has gone wrong, anyone may be able to chime in on the above problem?

1 Reply

Have you added the hostname you are using to access your NextCloud instance (in your browser) to config.php, in the trusted_domains setting?

You may need to locate this file using:

find / -name config.php

See also:


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct