TLS pass through NodeBalancer

Hi,

I want to pass through TLS to a service running on my linode. When I setup a NodeBalancer with two ports the non-TLS port works fine. But the one with TLS gives me errors. For instance when I use OpenSSL

openssl s_client -showcerts -servername <MY_DOMAIN> -connect <NODEBALANCER:PORT>

I see

139894479065728:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../ssl/record/ssl3_record.c:331

I get the same with curl. However on my localhost the very same commands work e.g

openssl s_client -showcerts -servername <MY_DOMAIN> -connect localhost:3456

Any ideas what is wrong. The very same software works on AWS without any issues using a network loadbalancer.

Thanks

2 Replies

It looks as if the NodeBalancer is terminating my SSL, how can I disable this?

Turns out it was the proxy protocol, setting it to None worked.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct