✓ Solved

Wordpress Site Showing Nginx Welcome After Rebooting Server

I installed WP using one-click and its been running great since March. I installed NGINX to the server but didn't set it up, so WP was still served from Apache.

Just last night I rebooted the Linode instance and now the site is unreachable

[https://femmebrandco.com/] - website link

When I visit the url of the server IP I see the 'welcome to nginx' page :/

It seems the reboot has altered the config but I can't seem to spot where. Appreciate any pointers

2 Replies

✓ Best Answer

Were both nginx(8) and apache2(8) started when the system booted?

If so, nginx(8) probably grabbed ports 80/443 first and is listening on them to the exclusion of apache2(8). apache2(8) probably errored out when it was started. Consult the appropriate logs to see if you can reconstruct what happened in your mind.

Try this:

  • shut down nginx(8); and
  • (re-)start apache2(8)

…and see what you get. Tell systemd(8) to not start the one you don't want at boot up:

sudo systemctl disable the_one_I_dont_want.service

If you want both, configure one to use different ports while you're testing or whatever. Don't forget to open those ports in your firewall.

-- sw

oohh shoot!

Yes restart. Of course

Thanks! (12hrs of server teardown just to restart apache :P)


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct