✓ Solved

How do I install a custom ISO like SNG7-PBX-64bit 2104?

I am trying to install asterisk and freepbx and was wondering how to install from an iso if this was even still possible anymore.. Any assistance would be appreciated thanks!

Google so far hasn't helped me and I did try to install from the old wiki things just didn't turn out all that well..

15 Replies

✓ Best Answer

I got it I am up and running thank you so much!!!

I am sorry my eyes glazed over this is some deep shit! Thanks but I was hoping it was something as simple as uploading a disk iso and booting from it somehow not a bunch of command line shit for me to screw up.. Why freepbx isn't one of the distros offered is beyond me anyway during installation oh well I will give this a shot but I have a feeling I am in for a rough time without any lubrication..

@lorentedford --

You know…I like a good expletive-laden rant as much as anyone…and have engaged in them myself…but there's a time and a place… This is not the place.

-- sw

Thank goodness I didn't use any expletives then! Just some description of what I am gliding through at the moment… Ugh.. this sucks.. I am may have done the whole dd thing wrong.. here is what I did..

curl https://downloads.freepbxdistro.org/ISO/SNG7-PBX-64bit-2104-1.iso | dd of=/dev/sdb

curl https://downloads.freepbxdistro.org/ISO/SNG7-PBX-64bit-2104-1.iso | dd of=/dev/sdb

It seems like your next step is to try to boot from /dev/sdb and install your distro on /dev/sda. If it doesn't work, you probably have to adjust the block size(s) on your dd command:

dd of=/dev/sdb ibs=xxxx obs=yyyy

Typically, you want ibs= and obs= (at least obs=) to be a multiple of 1024. The default is 512. See:


Also, you need to make sure that /dev/sdb is big enough to hold the installer image. There's some way for curl to give you this info a priori…I just don't remember what it is off the top of my head…

I looked at the guide… Except for all the futzing with GRUB (which you may not even need to do), it's remarkably the same as the instructions I used to install FreeBSD/NetBSD on a Linode…replete with a striped RAIDz3 ZFS pool in block storage (not recommended unless you have a large amount of memory).

-- sw

Yeah I might have really screwed this up.. I think I am going to take a break on it tonight and try again tomorrow thank you so much for your help @stevewi!

It might be better off to delete all the disks and try this all over from scratch.. Or maybe even delete the VM and start over from this point..

No need to delete the VM… Just delete the discs & reallocate accordingly. You install the installer image using recovery mode anyway…which is memory-based.

The recovery-mode image is a stripped-down Finnix distro that uses a memory-disc…it's pretty useful. It doesn't touch your VMs discs at all unless you run program (like dd) that writes to them. It's pretty sophisticated…but you can only use it from lish/glish so that's a disadvantage (no terminal scrolling, etc). Minor inconvenience, IMHO…

After you boot your custom distro the first time to make sure it works, merge your installer image disc(s) into /dev/sda or otherwise reallocate according to the needs of your application. The rule of thumb is that you can always make an allocated disc bigger…you need to be careful on shrinking (not impossible but some care required).

-- sw

Thank you so much!! I am still working on this just not having much luck booting to the drive and having the other drive show up to be installed to.

Make sure you have TWO boot configurations:

  • Installer: boot from /dev/sdb; /dev/sda is the installer target (obviously, you put the installer on /dev/sdb using Recovery Mode); and
  • Boot: boot from /dev/sda (you don't care about /dev/sdb…don't even give it a drive name)

You can create as many of these as you want…and label them however they make sense to you. FWIW, those of us who have worked with custom distros/non-Linux OSs have probably messed this up more than once. I know I have… I would hope that this is a common mistake.

-- sw

Wow!! I think I am getting it will be back with my results in a bit! This is where I screwed up your right on the installation boot config and then a regular boot config I think I got this now Wow I am so dumb some times when I read these things..

Thank you so much!!
Brb I promise!

Some things came up personally and I had to stop working on this but I am going to try and work on it tonight and will check back in here and let you know how it goes.. I tried it once but I think I might have messed up my dd to the drive and so I am redoing those now fresh in hopes that I did it right.

Ok so I have it booted up.. I am trying to install to the hard disk it shows now but it won't install to it..

So I assume you have two drives:

  1. one that your installer lives on (and the one you booted from); and
  2. one that is the target of the installer.

Since you're installer is running, I'm assuming #1 is ok.


  • Is #2 mounted?
  • Is #2 specified as the target of your installation?
  • Does #2 have a filesystem created on it (should be ext4)?
  • Does #2 have enough space on it to hold your installation?

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct