port 80 up and I search for my website ip address for my apache webserver and get "<ip addr> refused to connect"

When I booted up my server, I tried searching for my website and it refused to connect. Tried searching it on the same website but it still had the same issue. I checked my firewall rules to see that port 80 wasn't there for some reason but I tried to open with

sudo ufw allow 80/tcp

And got

Skipping adding existing rule
Skipping adding existing rule (v6)

When I checked ss -tulpn again, port 80 still wasn't there so I disabled the firewall rules and rebooted the server. I check which ports are open and it seems like port 80 was open this time.

Netid State Recv-Q Send-Q Local Address:Port Peer >Address:Port Process
tcp LISTEN 0 128 >* users:(("sshd",pid=472,fd=3))
tcp LISTEN 0 511 :443 >:* users:(("apache2",pid=471,fd=6))
tcp LISTEN 0 70 :33060 >:* users:(("mysqld",pid=508,fd=22))
tcp LISTEN 0 151 :3306 >:* users:(("mysqld",pid=508,fd=24))
tcp LISTEN 2 511 :80 >:* users:(("apache2",pid=471,fd=4))

I tried connecting with the site and I'm having the same issue.

While I'm not able to connect to the website, I'm still able to ping it for some reason? Does anybody know why this is happening?

1 Reply

Your web server is probably misconfigured. Just starting apache2 is not enough to guarantee a response.

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct