OpenVPN Linode Marketplace One-Click App Login Issues

Linode Staff

After deploying the openvpn app from the Linode Marketplace I go to the openvpn servers admin page and try to sign in but it keeps saying incorrect login even though I literally copy and pasted my password in there and it still says its wrong please tell me what is going on.

5 Replies

Hey there,

There's a known bug right now that's currently affecting the login credentials for the OpenVPN application from the Linode Marketplace. This should be fixed soon, but in the meantime, a workaround you can use is to:

  1. Connect to your Linode either via SSH or the Lish Console in Cloud Manager.

  2. Once logged in, you can run cat /var/log/stackscript.log | grep "Login as" to find the auto-generated admin password and use that to login to the admin portal. This should look like this: Login as "openvpn" with "$YOUR_RANDOM_TEMPORARY_PASSWORD" to continue.

  3. Once you've logged into the admin portal at $LinodeIP:943/admin/ using openvpn as the user and the password you obtained from the previous step, you'll want to navigate to the User Permissions page listed under the User Management menu on the left side of the page. If you are unsure where to find this page, you can visit it directly at $LinodeIP:943/admin/user_permissions.

  4. From there, click the pencil icon under More Settings, enter the password you'd like to use in the Password field under the Local Password section and then click Save Settings at the bottom of the page.

  5. If the web application asks if you want to propagate the changes to the running server you can click the Update Running Server button to confirm that.

After that, you can log out and log back in with the new password of your choice.

Good luck!

Hello, The steps here don't work for me, I run the command in LISH Console and I get "directory not found"

@Rocochet24 The password you receive from the cat command can be used on the OpenVPN admin screen. Just type in


and login with the password. There's no need to run further commands past cat

One year later and this is STILL happening. Not to mention that sometimes basic command like ufw are not even installed and cannot be installed… What are you guys paying these useless devs for? Disappointed, very. You were the only good VPN out there whom I trusted.

@CryptoPoe - Since this error was first reported, we made a change to the script that deploys the OpenVPN app so that the password is no longer manually entered when creating the Compute Instance. This is noted in the Deploying OpenVPN through the Linode Marketplace guide.

Instead, once the instance is fully deployed and the application is installed (2-5 minutes after provisioning), you can run the following command to retrieve the password:

cat /usr/local/openvpn_as/init.log | grep 'To login'

Alternatively, this information will be available when you open the Linode Shell (Lish):

Installation complete!
To login please use the "openvpn" account with "<secretPassword>" password.
(password can be changed on Admin UI)

Regarding utilities like UFW not being installed, this may be due to the installation not being fully complete when you've tried to access the instance. It is important to wait until the application is fully installed before attempting to access the Linode as connecting beforehand can cause complications.

If you're certain the installation process finished and utilities like UFW were not installed and couldn't be installed, I suggest sending in a ticket with the /var/log/stackscripts.log file attached so the Support Team can review it get an idea of possible issues. For what it's worth I ran two tests of the OpenVPN application and was unable to recreate the UFW issue.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct