✓ Solved

CentOS 8: AppStream Repository doesn't exist

Last week I created a fresh node with CentOS 8.

yum related commands like…

yum upgrade

…fails with a message…
Status code: 404 for http://mirrors.linode.com/centos/8/AppStream/x86_64/os/repodata/repomd.xml (IP: 2600:3c03:1::45a4:df28)
Error: Failed to download metadata for repo 'appstream': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Browsing to http://mirrors.linode.com/centos/8 there is no AppStream folder. I also don't see a BaseOS folder.

Is there a different Linode provided mirror that I should configure the server to? Or just kill this node and create one with CentOS Stream 8?


3 Replies

✓ Best Answer

CentOS 8 went end of life a couple months ago. Rocky Linux 8 is the "continuation" of CentOS which is available as an OS option on Linode.

CentOS Stream is based off the testing stream of RedHat so there might not be as much stability.

FWIW I haven't used either one, so I can't personally vouch for either.

Ok, thanks, I had forgotten about CentOS ending. I think I'll give Rocky a look. Thanks again.

You’re welcome. It’s easy to forget about the OS going EOL especially with the long support time.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct