My site ( has just started to exhibit a DNS_PROBE_FINISHED_NXDOMAIN issue out of nowhere, I'm pretty new to this having just been handed the keys very recently and don't really know how to troubleshoot and resolve the problem.

Any thoughts, steps I can take etc. would be massively appreciated.

2 Replies

It looks like there is a problem with your Linode server's port 80, most likely a firewall.

I can resolve your domain just fine:

dig +short

However a port scan is showing that your port 80 (http) is filtered. Note port 443 (https) is open:

nmap -p80,443
Starting Nmap 7.91 ( ) at 2022-02-08 09:42 EST
Nmap scan report for (
Host is up (0.086s latency).

80/tcp  filtered http
443/tcp open     https

This explains why does not work, however does.

In a typical web server configuration, visitors to the http site should be automatically redirected by the web server to the https site. Since your http port is not responding, visitors are never redirected.

Since I have the ability to see your Linode's Linux distribution, I'm going to assume that its using the default iptables firewall service. If I'm right, these commands should add the rules you need in order to allow port 80 traffic:

sudo iptables -A INPUT -p tcp --dport 80 -m conntrack --ctstate NEW,ESTABLISHED -j ACCEPT
sudo iptables -A OUTPUT -p tcp --sport 80 -m conntrack --ctstate ESTABLISHED -j ACCEPT

I also recommend checking out this bit of our guide on how to use iptables-persistent to make sure that your firewall rules are saved between server reboots:

Hi, you can troubleshoot dnsprobefinishednxdomain error by rebooting the internet connection. This can be done by unplugging the modem and router and then leaving them for around 30 seconds. Now plug the modem back in and wait for one minute. You can do the same with the router but just wait for two minutes before turning it back on. Launch the browser to see whether the error has been fixed yet or not. If it doesn't work, you can also reset Chrome flags. To disable Chrome Flags, add the following command in the address bar chrome://flags. From here, you can see which new features are active on the app, so just change the Enabled Chrome Flags to Disabled or tap Reset all at the top to restore the default settings. When you are done, exit and start the browser once again.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct