How to install docker registry with helm

I am following the documentation in this page and towards the bottom there is this code

helm install docker-registry stable/docker-registry -f docker-configs.yaml

When i run it, i get this error

WARNING: This chart is deprecated Error: unable to build kubernetes objects from release manifest: unable to recognize "": no matches for kind "Ingress" in version "extensions/v1beta1"

Is there an update to this guide or is there something that am missing?

3 Replies

I'll take a deeper look into the guide when I get a chance, but in the interim, you may wish to check the capitalization of the word "ingress". I believe that case is significant here.

When using helm, i dont have access to the yaml file, i think its downloaded from the charts
could it be possible that the chart is deprecated?
I really need this registry because i dont want to pay dockerhub to get private repos for my project

I am also getting the same error … I followed every step exactly … correctly replacing with own values as appropriate yet got same error as above

bump linode !!!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct