Volume FailedMounted

I am creating a mysql statefulset but I face this issues when I using the block storage
Warning FailedMount 116s (x5 over 2m4s) kubelet MountVolume.MountDevice failed for volume "pvc-7546d442d5134d74" : rpc error: code = Internal desc = Unable to find device path out of attempted paths: [/dev/disk/by-id/linode-pvc7546d442d5134d74 /dev/disk/by-id/scsi-0Linode_Volume_pvc7546d442d5134d74]

2 Replies

Our CSI driver had an update that can cause permissions issues with mounting Volumes for certain deployments. We've seen this is especially prevalent with PostgreSQL deployments. Our developers have identified the root cause of the issue, but I don't have an ETA for you for when a fix is going to be implemented.

With that said, I do have a workaround for you in the meanwhile. You can run the command below and then redeploy your workloads:

kubectl -n kube-system patch sts csi-linode-controller --type='json' \

-p='[{"op": "add", "path": "/spec/template/spec/containers/0/args/-", "value": "--default-fstype=ext4"}]' 

@watrick Any updates on this? I tried to apply this fix and it doesn't seem to have worked

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct