Database (BETA) secure transport on opencart

I am trying to install opencart on linode VPS and use database(BETA) as database.

once I process the install on step 3, and there goes error as follow
"Warning: mysqli::__construct(): (HY000/3159): Connections using insecure transport are prohibited while --require_secure_transport=ON"

is there any way to turn off the secure transport?

2 Replies

I am having a similar problem setting up Wordpress.
I found this this which allowed me to configure Wordpress to use SSL so you may have to do something similar.

Configure WordPress to use SSL
If all goes well so far, you can be confident that WordPress database connections will be unlikely to fail once configured. Now add your self signed SSL certificate to OpenSSL's trusted store:

On the command line, run:

sudo mv my-ca.crt /usr/local/share/ca-certificates/
sudo update-ca-certificates
The system's trust store is where WordPress will look for SSL certificates. Important: The file name of the certificate must only end with a crt extension. my-ca.crt is fine, but my-ca.pem.crt and my-ca.pem are invalid!

You must now instruct WordPress to use the system's trust store to connect to MySQL using SSL. Set the appropriate settings in the wp-config.php file of your WordPress installation:

// In wp-config.php, add:
define('MYSQL_CLIENT_FLAGS', MYSQLI_CLIENT_SSL);
At this point, WordPress will connect to the MySQL server through an SSL connection.

exactly same problem, and no solution, problem will be in the pdo and mysqli drives of opencart no one is ready for ssl connection, need to be modified only one guy modify for 1.5 version..
solution is allos disable ssl in database

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct