✓ Solved

Port 8080 unreachable

I have an app running on docker in a linode instance, and in theory it should open a port at 8080 that I can remotely connect to via HTTPS. I can't reach it. I have checked iptables and netstat and everything seems in order to me.

$ iptables -L -n

Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT tcp -- tcp dpt:8080

$ netstat -ltn

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp6 0 0 :::5355 :::* LISTEN
tcp6 0 0 :::9090 :::* LISTEN
tcp6 0 0 :::22 :::* LISTEN

1 Reply

✓ Best Answer

After trying several things I found the problem. Docker was pointing to Changing that for instead solved it.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct