Error Message: "Using 32768KiB of shared memory for push module in /etc/nginx/nginx.conf:66"

Hi,

On 2GB with 2 dormant portals with out much traffic.
Beginning on 21st April, every day around 1 AM IST (GMT +5.5 Hrs) 502 errors are thrown
Nginx restart does not help here. Only REBOOT gets the sites back into life.

Nginx log says

2018/04/22 17:58:34 [info] 3366#3366: Using 32768KiB of shared memory for push module in /etc/nginx/nginx.conf:66

All the digging lead to

https://github.com/perusio/drupal-with-nginx/issues/73
Whose remedy had solved the problem in a similar case.
" --------
This has all the symptoms of a problem specific to the push module. Try
disabling epoll and see if you can reproduce it.
-------- "

But I do not know how to disable this epoll which seems to have been enabled by default in nginx.

I am not against going to next plan but that is the not the solution I feel.

I run Drupals in linode and my nginx.conf looks like this. If you need sitesenabled.confs too, I can paste later.


user www-data;
worker_processes 1;
pid /run/nginx.pid;

events {
workerconnections 1024; multiaccept on;
use epoll;
}

http {

##
# Basic Settings
##

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
server_tokens off;

# server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;

##
# Gzip Settings
##
    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

##
# Virtual Host Configs
##

reserve 1MB under the name 'uploads' to track uploads

   #  upload_progress uploads 1m;

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
    client_max_body_size 10M;

}

mail {

# See sample authentication script at:

# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

# auth_http localhost/auth.php;

# pop3_capabilities "TOP" "USER";

# imap_capabilities "IMAP4rev1" "UIDPLUS";

server {

listen localhost:110;

protocol pop3;

proxy on;

}

server {

listen localhost:143;

protocol imap;

proxy on;

}

}


Any Help is appreciated

Rgds,

Raju

2 Replies

Hi,

I'm not familiar with this message myself but I'll see if I can assist.

But I do not know how to disable this epoll which seems to have been enabled by default in nginx.

Towards the top of your provided configuration profile epoll is mentioned, you may be able to comment out that line to disable the feature.

events {
workerconnections 1024; multiaccept on;
use epoll;
}

The final comment in this older, slightly unrelated conversation mentions that the "Using 32768KiB of shared memory for push module in" message is not an error so they may not be the root of your issue. If you have other errors in your nginx or php logs you may want to investigate those too. This guide covers the common causes of 502 errors.

Thanks Agracie

First apologies for posting the wrong nginx.conf
The actual file I am using has no mention of epoll anywhere

I shall paste the file later: first thanks for tracing me to the soutce of the problem - php-fpm

I restarted php-fpm and the 502 was gone!

I am pasting php-fpm log to find a solution!


[22-Apr-2018 06:25:04] NOTICE: error log file re-opened
[22-Apr-2018 17:56:41] NOTICE: Terminating …
[22-Apr-2018 17:56:41] NOTICE: exiting, bye-bye!
[22-Apr-2018 17:58:35] NOTICE: fpm is running, pid 3365
[22-Apr-2018 17:58:35] NOTICE: ready to handle connections
[22-Apr-2018 17:58:35] NOTICE: systemd monitor interval set to 10000ms
[22-Apr-2018 18:20:30] NOTICE: Terminating …
[22-Apr-2018 18:20:30] NOTICE: exiting, bye-bye!
[22-Apr-2018 18:22:00] NOTICE: fpm is running, pid 21712
[22-Apr-2018 18:22:00] NOTICE: ready to handle connections
[22-Apr-2018 18:22:00] NOTICE: systemd monitor interval set to 10000ms
[22-Apr-2018 18:22:04] NOTICE: Terminating …
[22-Apr-2018 18:22:04] NOTICE: exiting, bye-bye!
[22-Apr-2018 18:22:04] NOTICE: fpm is running, pid 24490
[22-Apr-2018 18:22:04] NOTICE: ready to handle connections
[22-Apr-2018 18:22:04] NOTICE: systemd monitor interval set to 10000ms
[22-Apr-2018 18:22:22] NOTICE: Terminating …
[22-Apr-2018 18:22:22] NOTICE: exiting, bye-bye!
[22-Apr-2018 18:22:52] NOTICE: fpm is running, pid 3362
[22-Apr-2018 18:22:52] NOTICE: ready to handle connections
[22-Apr-2018 18:22:52] NOTICE: systemd monitor interval set to 10000ms
[22-Apr-2018 18:56:24] WARNING: [pool www] child 3435 exited on signal 9 (SIGKILL) after 2012.082579 seconds from start
[22-Apr-2018 18:56:24] NOTICE: [pool www] child 4127 started
[22-Apr-2018 18:56:24] WARNING: [pool www] child 3708 exited on signal 9 (SIGKILL) after 1655.755117 seconds from start
[22-Apr-2018 18:56:24] NOTICE: [pool www] child 4129 started
[22-Apr-2018 18:56:24] WARNING: [pool www] child 3715 exited on signal 9 (SIGKILL) after 1614.711205 seconds from start
[22-Apr-2018 18:56:24] NOTICE: [pool www] child 4130 started
[22-Apr-2018 18:56:24] WARNING: [pool www] child 3436 exited on signal 9 (SIGKILL) after 2012.100865 seconds from start
[22-Apr-2018 18:56:24] NOTICE: [pool www] child 4131 started
[22-Apr-2018 23:09:02] WARNING: [pool www] server reached pm.maxchildren setting (5), consider raising it [23-Apr-2018 07:03:28] NOTICE: Terminating … [23-Apr-2018 07:03:28] NOTICE: exiting, bye-bye! [23-Apr-2018 07:05:23] NOTICE: fpm is running, pid 3351 [23-Apr-2018 07:05:23] NOTICE: ready to handle connections [23-Apr-2018 07:05:23] NOTICE: systemd monitor interval set to 10000ms [23-Apr-2018 07:39:01] WARNING: [pool www] server reached pm.maxchildren setting (5), consider raising it
[23-Apr-2018 16:32:05] WARNING: [pool www] child 3689 exited on signal 9 (SIGKILL) after 33832.745564 seconds from start
[23-Apr-2018 16:32:05] NOTICE: [pool www] child 8334 started
[23-Apr-2018 16:32:05] WARNING: [pool www] child 3412 exited on signal 9 (SIGKILL) after 34001.925354 seconds from start
[23-Apr-2018 16:32:05] NOTICE: [pool www] child 8335 started
[23-Apr-2018 16:32:05] WARNING: [pool www] child 4201 exited on signal 9 (SIGKILL) after 32272.206641 seconds from start
[23-Apr-2018 16:32:05] NOTICE: [pool www] child 8336 started
[23-Apr-2018 16:32:05] WARNING: [pool www] child 3846 exited on signal 9 (SIGKILL) after 33060.012292 seconds from start
[23-Apr-2018 16:32:05] NOTICE: [pool www] child 8337 started
[23-Apr-2018 16:32:05] WARNING: [pool www] child 3413 exited on signal 9 (SIGKILL) after 34001.941469 seconds from start
[23-Apr-2018 16:32:05] NOTICE: [pool www] child 8338 started
[23-Apr-2018 19:27:30] WARNING: [pool www] server reached pm.maxchildren setting (5), consider raising it [24-Apr-2018 06:48:46] NOTICE: Terminating … [24-Apr-2018 06:48:46] NOTICE: exiting, bye-bye! [24-Apr-2018 06:50:40] NOTICE: fpm is running, pid 3370 [24-Apr-2018 06:50:40] NOTICE: ready to handle connections [24-Apr-2018 06:50:40] NOTICE: systemd monitor interval set to 10000ms [24-Apr-2018 18:08:01] WARNING: [pool www] server reached pm.maxchildren setting (5), consider raising it
[24-Apr-2018 18:31:59] WARNING: [pool www] child 9869 exited on signal 9 (SIGKILL) after 1439.185452 seconds from start
[24-Apr-2018 18:31:59] NOTICE: [pool www] child 10201 started
[24-Apr-2018 18:31:59] WARNING: [pool www] child 6221 exited on signal 9 (SIGKILL) after 23481.057937 seconds from start
[24-Apr-2018 18:31:59] NOTICE: [pool www] child 10202 started
[24-Apr-2018 18:31:59] WARNING: [pool www] child 7738 exited on signal 9 (SIGKILL) after 10607.058441 seconds from start
[24-Apr-2018 18:31:59] NOTICE: [pool www] child 10203 started
[24-Apr-2018 18:31:59] WARNING: [pool www] child 9840 exited on signal 9 (SIGKILL) after 1618.344551 seconds from start
[24-Apr-2018 18:31:59] NOTICE: [pool www] child 10204 started
[24-Apr-2018 22:11:40] WARNING: [pool www] server reached pm.maxchildren setting (5), consider raising it [25-Apr-2018 07:57:11] NOTICE: Terminating … [25-Apr-2018 07:57:11] NOTICE: exiting, bye-bye! [25-Apr-2018 07:59:04] NOTICE: fpm is running, pid 3355 [25-Apr-2018 07:59:04] NOTICE: ready to handle connections [25-Apr-2018 07:59:04] NOTICE: systemd monitor interval set to 10000ms [25-Apr-2018 08:26:15] NOTICE: Terminating … [25-Apr-2018 08:26:15] NOTICE: exiting, bye-bye! [25-Apr-2018 08:41:22] NOTICE: fpm is running, pid 3376 [25-Apr-2018 08:41:22] NOTICE: ready to handle connections [25-Apr-2018 08:41:22] NOTICE: systemd monitor interval set to 10000ms [26-Apr-2018 00:11:34] WARNING: [pool www] server reached pm.maxchildren setting (5), consider raising it
[26-Apr-2018 04:43:31] NOTICE: Terminating …
[26-Apr-2018 04:43:31] NOTICE: exiting, bye-bye!
[26-Apr-2018 04:45:01] NOTICE: fpm is running, pid 17947
[26-Apr-2018 04:45:01] NOTICE: ready to handle connections

[26-Apr-2018 04:45:01] NOTICE: systemd monitor interval set to 10000ms

Now the nginx.conf I am using. I upgraded to 4 GB plan now!

==============
user www-data;
worker_processes 2;
pid /run/nginx.pid;

events {
workerconnections 768; # multiaccept on;
}

http {

##
# Basic Settings
##

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
server_tokens off;

# server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;

##
# Gzip Settings
##
    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

##
# Virtual Host Configs
##

reserve 1MB under the name 'uploads' to track uploads

   #  upload_progress uploads 1m;

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
    client_max_body_size 20M;

}

mail {

# See sample authentication script at:

# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

# auth_http localhost/auth.php;

# pop3_capabilities "TOP" "USER";

# imap_capabilities "IMAP4rev1" "UIDPLUS";

server {

listen localhost:110;

protocol pop3;

proxy on;

}

server {

listen localhost:143;

protocol imap;

proxy on;

}

}


If you wanna take a look at nginx access log. let me know.

Thanks again
Let us find a solution for this

Raju

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct