Kasm/Docker Stops Working After Linode Restart

Hey guys,

I am facing a weird issue.

So I had a server running KASMWorkspace and I decided to reboot the server.

Once the machine was back up and running, the server started acting weird.

  1. KASMWorkspace stopped working

  2. When I type "sudo docker -D" I get this message "chmod /var/lib/docker: read-only file system" and I get similar message for a lot of files. For instance when I type "touch game.txt" I get this error "touch: cannot touch 'game.txt': Read-only file system"

Seems like the reboot also messes up the mount system.

"cat /etc/fstab shows this >> "/mnt/1GiB.swap swap swap defaults 0 0"

I wonder if this command "echo '/mnt/1GiB.swap swap swap defaults 0 0' | sudo tee -a /etc/fstab" that I ran when installing KASMWorkspace is causing the problems? Because it erased everything else and put this in the fstab?

  1. A lot of other services that usually just work fine stopped working as well. For example the name resolution stopped working. So when I "ping google.com" nothing happens I get an error "ping: google.com: Temporary failure in name resolution" but if I "ping" then it works fine. When I look at the /etc/resolv.conf file it's empty even though it wasn't empty before reboot.

I thought something is wrong with my SSH connection, so I tried the LISH Console and same thing.

I thought something else must have happened so I deleted the server and launched another one. I installed KASMWorkspace and everything worked fine.

Then I decided to reboot just to check if it was me or something else is taking place.

So I did "reboot" and once again the same issue. Everything stopped working.

I need to reboot the server now and then because I want to use it for some other services.

Can someone help me please?

Thank you

0 Replies


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct