SSH problem trying to connect

any time i try to ssh to my kali server like so[ ssh -L 61000:localhost:5901 -N -l [username] [ip] ] i just get C:\Users>ssh -L 61000:localhost:5901 -N -l user@ip usage: ssh [-46AaCfGgKkMNnqsTtVvXxYy] [-B bind_interface] [-b bind_address] [-c cipher_spec] [-D [bind_address:]port] [-E log_file] [-e escape_char] [-F configfile] [-I pkcs11] [-i identity_file] [-J [user@]host[:port]] [-L address] [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port] [-Q query_option] [-R address] [-S ctl_path] [-W host:port] [-w local_tun[:remote_tun]] destination [command] and then when i try to connect through vnc it says that connection has failed i have can changed some of my info with [] i am just really lost. I am running windows maybe need open ssh install

1 Reply

C:\Users>ssh -L 61000:localhost:5901 -N -l user@ip

The -L option is malformed. Also localhost refers to your Windows machine…not the Linode. ip refers to the Linode. Try leaving the -L and -N options off completely (-N does nothing in this context). Like this:

ssh ip -l user

where user and ip are what you used before.

I am running windows maybe need open ssh install

The ssh that comes with Windows is OpenSSH. If it wasn't installed, you wouldn't have gotten the error message you got…

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct