Linode Marketplace Kali Linux Desktop missing tools

Linode Staff

When I install Kali Linux from the Linode Marketplace, the VNC Desktop does not have all the tools available.

How do I fix this?

1 Reply

I found the answer here:

Run sudo apt update && sudo apt install -y kali-desktop-xfce in a terminal session to install the new Kali Linux Xfce environment. When asked to select the “Default display manager”, choose lightdm.

I was not asked to select a display manager

Next, run update-alternatives --config x-session-manager and select Xfce’s option. If you would also like to remove the Gnome window manager, which we do not recommend until you are sure you are ready to, run apt purge --autoremove kali-desktop-gnome. Be sure to run this after setting up Xfce

I selected the default option. I did not attempt to purge gnome.

Next time you login after a reboot you will have the Xfce theme, if you did not run the update-alternatives command you can choose “Xfce” in the session selector in the top right hand corner of the login screen.

I did not do this yet, but opted to do the next step also instead to cut down on reboots

Q: I installed Xfce, but it doesn’t look like the preview. How can I get it to look the same?

A: If you are having issues, it may be that a config file is not set properly. First, backup .cache,.config, and .local. Next, running rm -r .cache .config .local and then rebooting will likely fix those issues.

I removed these files in my sudo user's home directory and rebooting did the trick.

The last step alone may have been enough to fix it.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct