Email address not forwarding... seems to be Postfix related

I'm having a problem with an email address that seems to be set up exactly the same way as every other email address on my Linode.

When I mail the address, I get the following bounce:

Technical details of permanent failure:

PERM_FAILURE: SMTP Error (state 13): 550 <>: Recipient address rejected: User unknown in local recipient table

( is obviously not the real email address).

In the /etc/postfix/virtusertable I have set up the following: user

I've checked it using:

postmap -q /etc/postfix/virtusertable

Which returns "user".

I've also tested that "user" can receive email with the following:

mail user

Which successfully delivers a mail, but if I type:


The mail does not arrive. When I check in /var/log/maillog I get the following:

Sep 22 11:09:35 li* postfix/smtpd[19800]: NOQUEUE: reject: RCPT from localhost.localdomain[]: 550 <>: Recipient address rejected: User unknown in local recipient table; from=<> to=<> proto=ESMTP helo=>Sep 22 11:09:35 li*** sendmail[19819]: l8MA9Z03019819:, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30084, relay=[] [], dsn=5.1.1, stat=User unknown

I've also tried setting up another virtual address pointing to the same user, and when I send to this, the mail is delivered without a hitch.

I'd appreciate if anyone has any ideas. I hope I've given all the necessary details. It's very frustrating because it seems like everything's set up as it the same way as every other email address, but this one isn't working.

Thanks in afvance,


2 Replies

Guess: you have a trailing (or leading) invisible character in the username in the table (i.e. 'user@', where '@' is some non-printing character). This looks okay in

the postmap output, but fails when you actually try to lookup the username.

Try piping the output of the postmap -q command to 'od -a'. Or just delete the whole line and re-enter it.

Hey, that seems to have worked.

The "od -a" command didn't seem to show anything unusual, but wiping the line and reentering it seems to have done the trick. I had originally copied it into PuTTY, so this time I typed it manually. It's possible something got carried in the the pasting.




Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct