✓ Solved

I cannot update php to version 7.4

I tried to follow the instructions noted in this forum as highlighted in the answer to this question: https://www.linode.com/community/questions/20926/how-do-i-upgrade-my-php-version

However, I tried doing so over weblish. I can't perform the first step because I encounter this error: https://ibb.co/6X6H3V7

I'm not sure how to proceed with updating php at this rate, and I'm seeing my wp-admin site slow down (likely because I didn't update php yet).

If there's anything you need to help diagnose and solve the problem, let me know. Thank you!

3 Replies

✓ Best Answer

Hi @Naphtap! Taking a look at the screenshot you shared, I see the following error message:

E: Sub-process /usr/bin/dpkg returned an error code (1) linode

The following link may help you resolve this issue so you can continue upgrading PHP.

How to Solve “Sub-process /usr/bin/dpkg returned an error code (1)” In Ubuntu

Let us know if you have any other questions!

Hello @rdaniels,

I got to step 3 in the link you provided since the first two steps didn't work. I first uninstalled the packages listed under "errors were encountered processing". Then, when I tried to install libpcre2-8-0, I returned the following error on the image below.


Furthermore, my website doesn't work anymore…

Please help; I have to update my blog tomorrow.

Hi @rdaniels,

I just fixed the problem. I had to point dpkg to Debian's repository list instead of Ubuntu's. I used the solution provided here to do so:


I then followed your solution and successfully updated php to 7.4.

Thanks for your help!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct