Problem delivering mail to

I'm having a problem sending mail to It is refusing to talk to my IP address.

To try to diagnose, I used the following:

telnet 25

When I run this from my local PC can start a conversation. However, when I run it from my Linode I get the following:


Connected to

Escape character is '^]'.

452 try later

Connection closed by foreign host.

Is anyone having a similar problem, and can anyone suggest a solution?

5 Replies

That's odd…if the smtp server is returning accurate error codes, and I assume it is, it looks like a server issue on their side. The 452 return code indicates:

Requested action not taken: insufficient system storage

How long has this been happening?

It's been happening for a couple of weeks. I only got around to investigating properly. One of my users would like his email forwarded to his address and hasn't been receiving any recently. It was forwarding correctly before that.

Everything looks okay at my end, but seems to be refusing SMTP connections from my Linode.

As I say, when I telnet to it from my local PC I have no problem.

Are you getting the 452 response immediately when you connect to port 25? Does it take 5 to 10 seconds? I assume you're not typing any commands first.

Where is your linode? (HE or Planet?)

From my HE linode:

% telnet 25
Connected to
Escape character is '^]'.
220 ESMTP Service
221 2.0.0 closing connection
Connection closed by foreign host.

[root@li7-51 ~]# telnet 25


Connected to (

Escape character is '^]'.

220 ESMTP Service

This is what I get from my linode.

Thanks for the info, and sorry for taking a while to get back. It seems to only be me that's affected.

I found mention of the 452 error here:

Though I wouldn't say the messages are "bouncing back" as such…

I have sent them a support request, so we'll see if that fixes it.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct