My server has stopped working and is getting worse

Recently I was told my website was not showing anymore. Seemed IPv6 DNS was an issue. So I tried to just disable IPV6 and see if it started to work. Wasn't the case and I put the option back on within webmin/virtualmin.

Apache was giving me this error in the error.log
[Fri Feb 03 00:00:02.891101 2023] [mpm_event:notice] [pid 725:tid 140466962445440] AH00489: Apache/2.4.38 (Debian) mod_fcgid/2.3.9 OpenSSL/1.1.1n configured -- resuming normal operations
[Fri Feb 03 00:00:02.891202 2023] [core:notice] [pid 725:tid 140466962445440] AH00094: Command line: '/usr/sbin/apache2'
[Fri Feb 03 00:00:02.891269 2023] [core:notice] [pid 725:tid 140466962445440] AH00052: child pid 1244 exit signal Aborted (6)

When I try to do an apt-update I was getting the following:
Err:1 sarge InRelease
Could not resolve ''
Err:2 virtualmin-buster InRelease
Could not resolve ''
Err:3 buster InRelease
Could not resolve ''
Err:4 buster/updates InRelease
Could not resolve ''
Err:5 buster-updates InRelease
Could not resolve ''
Err:6 virtualmin-universal InRelease
Could not resolve ''

bind has stopped working and so has mariadb. I'd think at this point it'd be easier to get a new server and copy over, however I can't because of the mariadb issue. Maria won't start and it says the following:

root@webserver:/etc/mysql# systemctl status mariadb.service
● mariadb.service - MariaDB 10.3.36 database server
Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2023-02-04 08:14:49 UTC; 2s ago
Docs: man:mysqld(8)
Process: 28136 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
Process: 28137 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=203/EXEC)
Main PID: 28137 (code=exited, status=203/EXEC)

Feb 04 08:14:49 webserver systemd[1]: Starting MariaDB 10.3.36 database server…
Feb 04 08:14:49 webserver systemd[28137]: mariadb.service: Failed to execute command: Permission denied
Feb 04 08:14:49 webserver systemd[28137]: mariadb.service: Failed at step EXEC spawning /usr/sbin/mysqld: Permission denied
Feb 04 08:14:49 webserver systemd[1]: mariadb.service: Main process exited, code=exited, status=203/EXEC
Feb 04 08:14:49 webserver systemd[1]: mariadb.service: Failed with result 'exit-code'.
Feb 04 08:14:49 webserver systemd[1]: Failed to start MariaDB 10.3.36 database server.

Yet I have done a chmod 777 to that just to try and get this issue resolved but it still doesn't

root@webserver:/etc/mysql# ls -l /usr/sbin/mysqld
-rwxrwxrwx 1 root root 20959416 Sep 30 11:07 /usr/sbin/mysqld

Any help is greatly appreciated. Tried opening a support ticket and kept providing information but have not received any help. This server ran fine for the past 2 years. This was a virtualmin marketplace image as well if that helps.

8 Replies

Boy! Howdy! It sounds like you're in a world of hurt…

  • I'd get professional help (local professional help). You're going to need it…

  • I'd archive the MariaDB database files immediately in a place NOT on your Linode and shut down your Linode permanently.

  • I'd scan those files with every tool at my disposal looking for viruses and compromise.

  • I'd educate myself about firewalls.

  • I'd spin up a new Linode with adequate firewall protection and resurrect your database and website there.

Good luck!

-- sw

Lot of ASSumptions there on what's in place and not in place. Not a very helpful response either on trying to get the mysql db up.

Lot of ASSumptions there on what's in place and not in place.

You posted here asking for FREE help…offering pretty minimal facts. I offered some. Now, you're calling me an ASS. That's not a very good look for you…

Good luck to you.

-- sw

You assumed I don't have a firewall, you assumed I haven't scanned the files, you went and told me to just move everything immediately. I was looking for pointers on the errors I provided. Not sure how you claim minimal facts when I gave you the errors and everything I've done and tried. You can claim it doesn't look good to me but you didn't answer the question even asked.

you didn't answer the question

He did answer. He told you what to do. That is what you asked us.

Any help is greatly appreciated

You lied. It wasn't.

Now you have pissed-off one of the most knowledgable Linode resources on the planet. It is a good thing that Steve is civil. Had you directed a post like that to me, I would have cut you a new one.

You sound so smart… tell us why you didn't have a mysql-dump backup of your database? (Answer: you are not all that smart.)

You owe Steve an apology.

Better yet, do us a favor… go away… and don't come back.

Thanks for tips Stevewi :)


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct