Mail to local users bouncing


I'm trying to configure Postfix on Centos, but when I send mail to local users, I'm seeing entries like this in /var/log/maillog:

Nov 29 06:54:18 li20-189 postfix/smtp[31632]: 1E0C2387AB: to=<localuser@li20-189.localdomain>, orig_to=, relay=none, delay=27, delays=27/0.02/0.09/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=li20-189.localdomain type=A: Host not found)

(the names have been changed to protect the innocent).

On my other linode, it's working correctly, and the equivalent log entry is:

Nov 29 05:06:07 li16-10 postfix/local[17662]: EB4B486108: to=<>, relay=local, delay=1, status=sent (forwarded as 7526386119)

So I'm trying to figure out why one is using li20-189.localdomain while the other is using, and where to change it.

Any help appreciated.


4 Replies

This is a complete stab in the dark, but check the myhostname configuration parameter in your file. It should be set to your system's FQHN.


That's, right?

It doesn't seem to be set on the one that's working, but I will try it later.



The problem seems to have been the myhostname setting, alright.

My only problem now is that I can't figure out why the other one works!

Thanks for the suggestion,


I'm guessing you system's hostname is set correctly on the one which was working and not on the other. Have a look in the docs for your Linux distro to determine how to set it correctly.



Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct