FreeBSD 13.2

I can get FreeBSD 13.2 installed by following However, this does not result in ipv6 working. Does someone have anything on doing that? I've found lots of stuff on getting ipv6 working with FreeBSD, but they're all some combination of very old or doesn't work on Linode.

2 Replies

Hey there,

You mentioned reading some older "very old" stuff on getting IPv6 to work, but I was curious if you had seen this one from 3 years ago:

It is very in-depth, and while not the same version of FreeBSD, it looks like most of the information should be consistent with the current version.

There are even some references to an e-book on "no-nonsense open BSD" configurations, so if you have not seen it already, that may be a good starting point.

This documentation on setting up a Native IPv6 router may also be useful to your end goal:

Hopefully that helps!


Two lines were enought to get it working a bit

ifconfig_vtnet0_ipv6="inet6 accept_rtadv"

(You could pfctl -d to disable PF while debugging).

However… when having daemons on UDP/TCP ports, suddenly traffic doesn't arrive correctly anymore. It's frustrating. And in NixOS I experience the same.

Therefor I additional am defining the gateway explicitly, conform the suplied details in the Network Tab of this Linode at the cloud panel.

ifconfig_vtnet0_ipv6="inet6 accept_rtadv"
ifconfig_vtnet0_alias0="inet6 2a01:7e01:x:x::80 prefixlen 128" # extra addr / additonal range

That seem to have solved the problem.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct