robots.txt not found nginx

I keep getting a message from my SEO dashboard that the “robots.txt” is returning an error.


When I run a search in the linode glish, it says no directory exists. When I try to use a plugin on our Wordpress site to create a robots.txt file, the site or server crashes.

When I run /?robots=1 it works. What do I do now? nginx and Ubuntu

user-agent: *
Disallow: /wp-content/uploads/wpo-plugins-tables-list.json
Start Yoast Block


User-agent: *


End Yoast Block

1 Reply

By default, WordPress should be dynamically generating its own response to robots.txt requests using PHP, rather than relying for a robots.txt file on the server.

My best guess is that there's something in your nginx configuration which is failing to pass the request to PHP to generate the file. The solution near the bottom of this page might work for you:


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct