✓ Solved

Add more IP v6 from subnet

Hello, I'm an end user with no experience in networking and Unix so I wanted to ask you something.

I am using Ubuntu 20 and used this command to add v6 IP address

ip -6 addr add 2600:3c08::xxxx:xxxx:xxxx:xxxx dev eth0

I can ping it on local but when I ping this v6 IP address outside, I got status "loss 100%".

How to make it accessible from the internet?

BTW, with other provider like vultr, I can ping new added IP v6 without any configuration.

Thanks!

3 Replies

✓ Best Answer

If your server was deployed with Network Helper/Auto-Configure Networking on, then network configurations would have been stored to /etc/systemd/network/05-eth0.network for Ubuntu 20.04, so you should be able to add the address to that configuration with a text editor. I tested it on my own server and that worked, whereas ip -6 addr add made changes that didn't persist through reboot.

That said, I'm not sure what other steps in this process you've taken, so I'm going to give an overview of everything that typically needs to be done to use addresses from an IPv6 routed range.

First, you'd need add a routed range to your server from Cloud Manager.

Next, you'd need to disable Auto-Configure Networking for your instance if that's turned on.

You can then go to the guide for manual network configuration which then links to specific guides for reach distribution.

Thank you so much, after add the routed range, I can use additional IP v6 address.

Thank you so much for the solution.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct