Apache Virtual Hosts Trouble

My primary domain functions,


A hosted domain for a friend works fine,


and now I tried adding a domain for a family member…


Which does not work, it appears apache is trying to point to "/" instead of the /home/areawiderepair.com/public_html folder.

here is my httpd.conf


 <virtualhost"">ServerName triptoy.net
 ServerAlias www.triptoy.net
 DocumentRoot "/var/www"
 ScriptAlias /cgi-bin/ /var/www/cgi-bin/</virtualhost> 

 <virtualhost"">ServerName slivovitzmusic.com
 ServerAlias www.slivovitzmusic.com
 DocumentRoot "/home/slivovitzmusic.com/public_html"
 ScriptAlias /cgi-bin/ /home/slivovitzmusic.com/cgi-bin/</virtualhost> 

 <virtualhost"">ServerName areawiderepair.com
 ServerAlias www.areawiderepair.com
 DocumentRoot "/home/areawiderepair.com/public_html"
 ScriptAlias /cgi-bin/ /home/areawiderepair.com/cgi-bin/</virtualhost> 

Anyone else see what the problem is?

11 Replies

Have you re-loaded Apache?

> Have you re-loaded Apache?

Yes, and had to reboot for another reason… Neither worked.

Looks like its working to me?

It looks fine to me as well, but if you go to http://www.areawiderepair.com/ it tells me forbidden, you do not have access to "/"

The other two work fine.

I have an index.html file in that directory so this shouldnt be the case…

Well, problem one is that www.areawiderepair.com points to yahoo servers. Did you forget to update DNS? Or has it just not propagated yet?

As for the error you're seeing, it looks a lot like a permissions or ownership problem on the directory or index file.

propagation. what I see is:

You don't have permission to access / on this server.


Apache/2.2.3 (Debian) PHP/5.2.0-8+etch10 Server at areawiderepair.com Port 80

Yep.. the problem was the permission! thanks

You've still got DNS problems., as of 1300 CST Feb 9. I think you need to update the registration to point to your new nameserver(s).

This is still fudged. The DNS resolvers have been fixed but it still claims "/" is inaccessible. I don't know what happened, one moment I could see the page I created on the server and all of a sudden its back to forbidden. I didn't change anything to cause it to stop working….

Anyone have any ideas?

Doh! Nevermind….

Somehow the permissions were messed up, again? Anyone have a recommendation on the proper permissions to have on public_html and the files within?

Directories: 0755 = drwxr-xr-x Files: 0644 = -rw-r--r-- CGIs: 0755 = -rwxr-xr-x I've see strange problems where file permissions were changing for no apparent reason. It was because of the [FTP|SFTP] client software used to transfer files to the server. If you're seeing that, get a better client.

I use ISPConfig (http://www.ispconfig.org) to manage lots of websites with email (including antivirus and antispam), ftp, and other functionality. It's a free product and eases the administrative burden of server management.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct