early on stumbling blocks on fresh Ubuntu 8.04 LTS install

I just kicked my old deb install and gave the new Ubuntu 8.04 image a shot.

The few clicks for it went smoothly till I opened the AJAX console and logged in. So far so good. Problems started happening when I ran aptitude safe-upgrade.

I started getting all different type of errors.
> Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Encoding.pm line 16.

Use of uninitialized value in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.

debconf: delaying package configuration, since apt-utils is not installed

(Reading database … 8561 files and directories currently installed.)

Preparing to replace util-linux 2.13.1-5ubuntu1 (using …/util-linux2.13.1-5ubuntu2i386.deb) …

install-info(ipc): no file /usr/share/info/dir, retrieving backup file /var/backups/infodir.bak.

cp: cannot create regular file `/usr/share/info/dir': No such file or directory

install-info(ipc): copying /var/backups/infodir.bak to /usr/share/info/dir failed, giving up: No such file or directory

… … …

Errors were encountered while processing:


E: Sub-process /usr/bin/dpkg returned an error code (1)

A package failed to install. Trying to recover:

dpkg: error processing util-linux (--configure):

Package is in a very bad inconsistent state - you should

reinstall it before attempting configuration.

Errors were encountered while processing:


Reading package lists… Done

Building dependency tree

Reading state information… Done

Reading extended state information

Initializing package states… Done

Building tag database… Done

1# apt-utils not installed

2# locale nowhere to be found

3# /usr/share/info directory completely missing

Point 3# fixed by creating the directory.

Point 1# solved by copying the the apt-utils package over and installing it.

Still stuck on 2# though.

Who would have thought that such a simple task as running aptitude on a freshly installed system could lead to this?

Same result if runnign apt-get on the fresh install. (tried it after redoing the install just to have a fresh system to start of nothaving run aptitude on it).

… anybody else had this?

7 Replies

I believe the locales package should fix some of those issues.

aptitude install locales


Aye, so it did indeed.

Just weird … haven't had this happen to me before.

I'm having this same problem, and "aptitude install locales" didn't seem to work. Any ideas?


I started out fresh.

This is what I did.

Downloaded following packages from the Ubuntu mirrors.


belocs-locales-bin2.4-2.2ubuntu7i386.deb (dependancy of locales)



scp'ed them over.

First dpkg -i apt-utils. Then belocs, then locales and finally wget.

Somewhere in the process /usr/share/info was also created.

I kept getting locale-related warnings until I installed the language-pack-en package also.

I used

localedef -i en_US -c -f UTF-8 en_US.UTF-8

after I installed the locales package. That fixed the locale problem for me.

If locales is already installed,

dpkg-reconfigure locales

and generate your local locales.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct