Firewall ports are closed following maintenance

Linode Staff


After the recent host maintenance, my Linode restarted but the rules I had configured for OpenVPN forwarding through my firewall stopped working.

Have you guys blocked any ports following the maintenance?

Thank you.

3 Replies


I can confirm that we have not blocked any ports, however I think I may know what's going on here. It is not uncommon for us to see this after a host reboot, as what we have found is that often times either iptables was configured to allow a service through the firewall, but not to reload the configured rules automatically at boot, or a service - such as OpenVPN - has not been configured to start automatically at boot. There are a couple of ways to address this situation. If the issue is firewall-related, the information below should help get you pointed in the right direction.

If you are using a Debian-based distribution - such as Debian or Ubuntu - then you will want to use either iptables-persistent or UFW to accomplish this. I have provided links to guides for both above, but I think you'll find that UFW is the easiest to use.

If you are using a FirewallD distribution - such as CentOS - then you can use the firewall-cmd command to set your rules again. A guide on this has also been linked above.

If it turns out that the firewall is not the problem, then you should run

sudo netstat -plunt

to verify that the OpenVPN service is running and start it back up if it's not. I'm also including the link to our Reboot Survival Guide, which contains more information on all of these topics, including instructions on setting services to run at boot for most popular Linux distributions.


Thank you for the fast reply. For some reason the default iptables loaded instead of the configured one after the restart. I made a backup of the iptables rules so I was able to restore it.

Everything is up and running.

Thank you for your quick response!

Hey again,

Not a problem! I'm glad to hear that I was able to help get you back up and running! Just let us know if you have any other issues and we'll be happy to help out in any way that we're able!


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct