Strange Apache VHost Problem


I just moved my server from Fedora to CentOS and I'm having a rather strange config problem. I use RoundCube Webmail and when I try to login I get redirected back to the login form without any error. I also have SimpleID and have the same issue, so it seems to be a problem with the short URL's (e.g., as that's what they use and I don't seem to be having any problems with anything else.

The strange thing is that it only happens on subdomains. If I setup an alias so I login at "" it works fine, If I change the config so it's accessible at "" it also works. But, "" does not.

Btw, a successful login for RoundCube redirects to "" and one for SimpleID is ""

This setup works fine on another server with an almost identical configuration, so I'm very confused.

Any help would be greatly appreciated.

7 Replies

Looking through the RoundCube config file (located in config/ I see the following snippet:

// session domain:
$rcmail_config['session_domain'] = '';

You many want to try setting it to "" or "" and see what happens. Hope this helps!

I tried what you suggested and there was no effect.

I'm pretty sure it's an Apache problem , but nothing about this makes sense.

Going to try reinstalling in a while, maybe I messed up somewhere.

I do not think you meesed it up.

More likely there is a problem with apache version. Do you remember what apache and php version you had before? did you check php.ini? I have never used RoundCube Webmail, but it is based on php, right?


If I setup an alias so I login at "" it works fine, If I change the config so it's accessible at "" it also works. But, "" does not.

Are you sure you've set up your DNS for that subdomain correctly ( seems to exist – but perhaps that's the working version), as well as your virtual host settings on Apache?

The only other point is this bug, since fixed in more recent versions.


Are you sure you've set up your DNS correctly for that subdomain correctly

This is exactly my question! Can you check if you the subdomain has propagated?

If you are using, then that has propagated an is pointing to

; <<>> DiG 9.3.2 <<>> @localhost ANY
 ; (2 servers found)
 ;; global options:  printcmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16199
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

 ;        IN  ANY

 ;; ANSWER SECTION:    86400   IN  A

 ;; Query time: 104 msec
 ;; WHEN: Fri Apr 17 15:59:01 2009
 ;; MSG SIZE  rcvd: 51

Thanks for all the suggestions guys. I feel really stupid now, turns out it was a problem on my computers end, probably an old session cookie or something.

Btw, yes is my domain :)


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct