Apache won't start on Ubuntu 9.04, no errors reported

Apach fails to start without posting anything to error.log. apache2ctl configtest returns Syntax OK. I have no idea where to begin debugging this.

Here are the contents of /etc/apache2/sites-available/default:

 <virtualhost *:80="">ServerAdmin webmaster@localhost

        DocumentRoot /var/www
        <directory>Options FollowSymLinks
                AllowOverride None</directory> 
        <directory var="" www="">Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all</directory> 

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <directory "="" usr="" lib="" cgi-bin"="">AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all</directory> 

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <directory "="" usr="" share="" doc="">Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from ::1/128</directory></virtualhost> 

Here are the contents of one of my virtual hosts. All others match except for domain.

 <virtualhost *:80=""># Admin email, Server Name (domain name) and any aliases
  ServerAdmin webmaster@webolutionary.com
  ServerName  webolutionary.com
  ServerAlias www.webolutionary.com

  # Index file and Document Root (where the public files are located)
  DirectoryIndex index.html
  DocumentRoot /var/www/vhosts/webolutionary.com/htdocs

  # Custom log file locations
  LogLevel warn
  ErrorLog  /var/www/vhosts/webolutionary.com/log/error.log
  CustomLog /var/www/vhosts/webolutionary.com/log/access.log combined</virtualhost> 

Here is /etc/apache2/ports.conf

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

 <ifmodule mod_ssl.c=""># SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443</ifmodule> 

apache2.conf is unmodified from the original.

3 Replies

How are you determining that httpd isn't starting?

It tells me. ;-)

root@li64-240:/etc/apache2# /etc/init.d/apache2 start
 * Starting web server apache2                                           [fail]

Restart does the same.

Figured it out. It was a bad log path in my virtual host configurations.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct