CNAME forwarding question

This should be dead simple, but for the life of me I can't seem to get it right…

Have a blog @, lets say Have a domain name, Just trying to point the domain to the blog using a cname.

So, both and should point to Have tried a CNAME entry with aliased to, which Linode DNS manager turns into www. But, if I hit, it seems to go into essentially a loop…

I have no A entries at all, as this should be just a staright forward.

Any help for this clueless user?


7 Replies

Works fine for me in both Chrome and Firefox. Maybe your DNS cache needs to be flushed. If you're on XP, open a Command Prompt and run ipconfig/flushdns, then restart your browser. Otherwise, maybe your ISP is caching it, and you just have to wait.

You can check whether the DNS is set up correctly with the host command:

$ host is an alias for has address

You should see something similar to this.

The other half is that Wordpress must be set up to respond to requests for This is known as name-based virtual hosting or, on, domain mapping.

So here is what my host looks like:

> root|production[~]=> host CNAME CNAME A A A A A A

I think the problem lies on my end with my dns settings here at linode. Here are my settings. I have no A records at all, have the linode nameservers, and just the one CNAME record:

Hostname: www

Aliases To:

TTL: 14440 (4 hours)

Problem remains with hitting and it going into essentailly an endless loop it appears. Should there be an A record of any type? How would I also redirect to

Anyone see anything wrong with them?

No, you're not pointing to Linode name servers:             172800  IN      NS             172800  IN      NS             172800  IN      NS             172800  IN      NS
;; Received 179 bytes from in 149 ms


No, you're not pointing to Linode name servers:             172800  IN      NS             172800  IN      NS             172800  IN      NS             172800  IN      NS
;; Received 179 bytes from in 149 ms

For business reasons, I can't post the actual correct domain… is just a random name I choose. The domain in question is indeed pointing at linode.

People are trying to help, but by disguising your domain name and using one that actually exists you're sending everyone down the wrong track - is reserved specifically for use in cases like this.

But… I work here so I get to cheat. :)

I looked at your domain and the is pointing at wordpress, but they are redirecting to which doesn't exist. You need to tell wordpress that your blog address is


Ah, sorry about that, thought it would be such a simple issue that it wouldn't involve any actual network stuff, just a quick text response.




Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct