iSCSI Error on boot up

Linode Staff


When I boot up my Linode using Ubuntu 18.04 with the Latest 64 bit 4.15.13-x86_64-linode106 kernel. I am receiving the following error.

    [FAILED] Failed to start Load Kernel Modules.^M
    See 'systemctl status systemd-modules-load.service' for details
    A start job is running for iSCSI in…r daemon (iscsid)
    [FAILED] Failed to start iSCSI initiator daemon (iscsid)

2 Replies


The error you are seeing is a warning, but should not impact performance. The Linode kernel does not have the necessary kernel module installed for iscsid.service, which is enabled by default on Ubuntu 18.04. I suggest using Grub 2 as it is our default kernel option with newer distributions and has the necessary kernel modules.

This works great! Problem solved.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct