Need help Installing XSL and libxslt to linode server


I am trying to configure/install XSL into the PHP version currently on my linode server (PHP 5.2). Linode instructed me to read up on this page as I have to connect to my linode server via SSH: … e_with_ssh">

I’m on windows so I downloaded putty and attempted to connect to my server with my IP address in Putty and immediately got an error message saying “Network error”. Can anyone tell me why I got this error and how to get around it so I can connect to my linode server with SSH.

Once I’ve connected to the server with SSH how do I install XSL and libxslt into the current PHP version from there?

Any help is appreciated


3 Replies

Do you have a firewall on your Linode? Check if port 22 is blocked.

On Debian/Ubuntu, apt-get install php5-xsl will probably do what you need. On CentOS, try yum install php-xml.

Thanks for the reply, that's definitely a start… I'm still trying to fimiliarize myself with the linode control panel and I have no idea where to check if port 22 is blocked, I've been looking around and can't find anything… How do I check that?


Running (as root) iptables -nvL will show the current firewall rules. Of course, you'll need to be logged into your Linode - try the AJAX console.

Changing your firewall settings depends on exactly what OS and administration tools you are using. It is not handled through Linode's web interface, though.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct