Trying to get permalinks working in WordPress

Avatar forum:Timelord 8 years, 12 months ago

Hi all,

New Linode user here. Very excited about it all so far, and just got my personal web site up and running here. I'm trying to get permalinks working in WordPress and for some reason I just can't figure it out.

I've turned AllowOverride to All everywhere I can find it and made sure FollowSymLinks is enabled everywhere I can find it. I've set up .htaccess the way WordPress tells me to, etc. But for some reason it still isn't working.

Any ideas what else to try here? I feel like I'm being obtuse and missing something obvious because this shouldn't be that hard.

Thanks!

4 Replies

Make sure that modrewrite is installed within Apache. Check your httpd.conf for: "LoadModule rewritemodule modules/mod_rewrite.so".

If you are using virtual hosts, you will need your AllowOverride statements within the virtual host container:

Options FollowSymLinks

AllowOverride All

That was it… I just ran a2enmod rewrite and that fixed it. I knew it had to be something simple. Thanks so much! 8)

I'm having some new confusion now… I set up another virtual host with an identical configuration to the first (where permalinks are working fine), but permalinks aren't working at all on the new host. What could be causing that?

EDIT: Never mind, it was an .htaccess problem. I thought I was writing changes to the file but I wasn't.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct