Ubuntu postfix squirremail imap connection gets dropped


Trying to configure my mail server to work using the folowing tut

~~[http://library.linode.com/email/postfix/postfix-courier-mysql-ubuntu-8.04-hardy" target="_blank">](http://library.linode.com/email/postfix … 8.04-hardy">http://library.linode.com/email/postfix/postfix-courier-mysql-ubuntu-8.04-hardy](

Then using the next tut for virtual domains

~~[http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-ubuntu8.04" target="_blank">](http://www.howtoforge.com/virtual-users … ubuntu8.04">http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-ubuntu8.04](

However, when i try to login to squirrelmail with the user i made it says "Error: Connection dropped by imap server"

I dont get any errors in mail.log or any other log file.

Is there anyone whos had the same problem or knows the answers?

Also im really confused about the DNS set up given in my linode account. I add a domain e.g. mydomain.com and it sets up an automatic mail subdomain e.g. mail.mydomain.com

When im setting up postfix etc, which one do i use, is it the mail.mydomain.com or just mydomain.com.

There are several settings in postfix like hostname etc. should some be mail.mydomain.com and some others be mydomain.com

The actual email addresses should these be sales@mail.mydomain.com or sales@mydomain.com

If somebody could bring some clarity to my situation i would really appreciate it and it would save me hours of trial and error

Cheers Klinode

7 Replies

i see this person has solved the error themselves,

~~[http://www.linode.com/forums/viewtopic.php?t=5081&highlight=squirrelmail" target="_blank">](http://www.linode.com/forums/viewtopic. … uirrelmail">http://www.linode.com/forums/viewtopic.php?t=5081&highlight=squirrelmail](

How do i implement a salt? what is it? cheers

Sounds like your imap server isn't running. Try telnet localhost 143. You should get the imap server. If you don't get the server response, then look at your logs and see why it is not running.

Try ps auxw | grep [name of imap server]. You should see the imap process. If not you either haven't started imap or your configuration has an error.

I use dovecot for an imap server. You might try that if you have no luck with courier.

Regarding dns and postfix. This is more complicated. Start with the default postfix files (main.cf and master.cf). Start postfix and telnet localhost 25 if you get an answer, type ehlo localhost you should get a response from postfix showing some of it's settings. If so, type quit and try sending or receiving email. You can look at /var/log/maillog and see what is happening.

Good luck. The best way to learn is get in there and try things. Make minor changes until you get things running the way you want.

yep, im having no problem telnetting, all of these things work for me.

The problem i am having is that im confused about the mail.mydomain.com ive been given on my linode and where to use it to configure postfix. The examples in the linode library for instance all use server.mydomain.com . Why? when i have been automatically set up a mail.domain.com subdomain already - this is confusing…

when i add a new doman e.g. mydomain.com to my linode acccount it asks me if i want to set up a mail subdomain for that domain. So it sets up mail.mydomain.com . Is this all set up and ready to use in postfix? Is there anything further i need to do with mail.mydomain.com to get it working like adding A or MX records (MX seems already to be set and A is already linked to mydomain.com's ip address)

im pretty sure all this has to do with the wrong hostname being set in postfix e.g. when using mail.mydomain.com my mail.log states that "mail loops back to myself" I cant find an answer to this question on google, because it seems specific to linode

do i set up emails as sales@mail.mydomain.com or sales@mydomain.com?

I would really be grateful for some answers to these questions

Try adding this:

appenddotmydomain = no

myhostname = mail.yourdomain.com ##your real fqdn

Pound out all other references to domain ie my.domain.com

stop and restart postfix and try it again.


Try adding this:

appenddotmydomain = no

myhostname = mail.yourdomain.com ##your real fqdn

Pound out all other references to domain ie my.domain.com

stop and restart postfix and try it again.

Hi, I already have

appenddotdomain = no

myhostname is already the same as shown above

Im not sure where my.domain.com comes from???? why would i have this in my conf file? Also im interested to find out what pounding out references means?


ok… so if i try to make it a bit more simple.

How does the

> mail.mydomain.com

subdomain in the linode DNS manager relate to the

> server.yourdomain.com

example in this tutorial ~~[http://library.linode.com/email/postfix/postfix-courier-mysql-ubuntu-8.04-hardy" target="_blank">](http://library.linode.com/email/postfix … 8.04-hardy">http://library.linode.com/email/postfix/postfix-courier-mysql-ubuntu-8.04-hardy](

Do I just use mail.mydomain.com instead of server.yourdomain.com???


i finally figured this out, it was the transport_maps section of postfix main.cnf that was causing me the trouble. i have to comment it out and keep changing the name in transport.sql table


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct