There goes my day. :(

I upgraded one of my nodes to Ubuntu 10.04 no sweat, so I went ahead and upgraded the other one.

Except that I forgot to edit /etc/fstab first so when I rebooted it, it claims the system is running but I can't connect to it. So I attempted to build a finnix recovery, and it doesn't work.

I have the Finnix configured exactly how it is here: … x-recovery"> and yet when I launch the console I just get a blank console screen. Nothing happens.

So I went to restore a backup snapshot I made right before the upgrade… only to be told by the backup system my node has no free space on it to restore the backup to.

What do I do? I have TOO much data on this server to lose it, so I'm being very cautious about anything I do at this point. Quite frankly, I'm a little bit more than worried.

4 Replies

Set config profile to "init=/bin/bash" mode. Save, reboot. Log onto console. At prompt: "mount -o remount,rw /". Make any fixes. sync, revert profile to normal runlevel, save, reboot. Rejoice.


I wasn't sure which profile you meant so I tried that on my Finnix first and the Ubuntu second. No go on either, I'm still getting a blank screen when I try to launch the console. I even tried it in Chrome and Safari to make sure FireFox wasn't screwing with me, and no luck there either.

I'm going to go jump off my front porch, I'll be right back. (PS: Thank you for the fast response, I was hoping this was going to be a "You're a life saver" reply but the daemons are out to get me)

Try working around the ajaxconsole thing - instead, you can access the console via SSH, too:

ssh <– This info is on the console subtab. You'll need to first set a Lish password.

Give that a shot.


Ahahaha, to heck with "launch console". That did it.

Thank you, thank you, thank you.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct